JasperReports - Error compiling report expressions class file
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JasperReports - Error compiling report expressions class file

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Article ID: 116273

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Updated On:

Products

CA Spectrum

Issue/Introduction

The following error is displayed instead of the parameter page for some reports such as Alarm Log-Selected Devices and Models and Availability Selected Devices:

Errors were encountered when compiling report expressions class file: 

2. ReportUtility cannot be resolved to a type value = new ReportUtility().getCurrentTimeZoneOffset(((java.util.TimeZone)parameter_REPORT_TIME_ZONE.getValue()) )+ (long) (new Date().getTimezoneOffset()); //$JR_EXPR_ID=22$
3. ReportUtility cannot be resolved to a type value = new ReportUtility().addMinutesToDate(-((java.lang.Long)variable_v_offset.getValue()), new ReportUtility().getBeginDateasTimestamp( ((java.lang.Integer)parameter_p_dateSelectionMode.getValue()), ((java.lang.Integer)parameter_p_preDefTimePeriod.getValue()), ((java.lang.Integer)parameter_p_daysOrHours.getValue()), ((java.lang.Integer)parameter_p_userDefTime.getValue()), ((java.sql.Timestamp)parameter_p_beginDate.getValue()), ((java.util.TimeZone)parameter_REPORT_TIME_ZONE.getValue()), ((java.util.Locale)parameter_REPORT_LOCALE.getValue()) )); //$JR_EXPR_ID=23$
4. ReportUtility cannot be resolved to a type value = new ReportUtility().addMinutesToDate(-((java.lang.Long)variable_v_offset.getValue()), new ReportUtility().getBeginDateasTimestamp( ((java.lang.Integer)parameter_p_dateSelectionMode.getValue()), ((java.lang.Integer)parameter_p_preDefTimePeriod.getValue()), ((java.lang.Integer)parameter_p_daysOrHours.getValue()), ((java.lang.Integer)parameter_p_userDefTime.getValue()), ((java.sql.Timestamp)parameter_p_beginDate.getValue()), ((java.util.TimeZone)parameter_REPORT_TIME_ZONE.getValue()), ((java.util.Locale)parameter_REPORT_LOCALE.getValue()) )); //$JR_EXPR_ID=23$

 

Environment

Spectrum 10.2.0 or greater integrated with Jasper

Cause

Possible root causes:

Time Zone mismatch between the OneClick+SRM and JasperReports machine.

Need to re-deploy and re-run the Jasper integration

Resolution

Sync the timezone setting on both the Jasper and SRM systems

If a sync of the timezones does not resolve the issue, do the following:

1. Log into the OneClick web pages as an ADMIN user

2. Click on the Administration link

3. Click on the Report Manager link

4. Click on the Jasper Integration link

5. Click on the Re-deploy button

6. After the re-deploy has finished, re-run the Jasper integration by doing the following:

    a. Click on the blue Integration Components link and download the spectrumConfigInstaller.jar file

    b. Copy the spectrumConfigInstaller.jar file to the <CABI Directory>/java/bin directory on the Jasper system

   c. If on Windows:

       i.   Log into the Jasper system as an user with Administration privileges
       ii.  Start a cmd
       iii. cd to the <CABI Directory>/java/bin directory and enter the following command:

java -jar spectrumConfigInstaller.jar -install

    d. If on Linux:

        i.  Log into or su to the root user on the Jasper system 
        ii. cd to the <CABI Directory>/java/bin directory and enter the following command:

./java -jar spectrumConfigInstaller.jar -install

    e. Reboot the Jasper system