Distribution Status Error: Failure when opening the Container at the Domain. No order could be executed.
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Distribution Status Error: Failure when opening the Container at the Domain. No order could be executed.

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Article ID: 116267

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Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

While distributing software from the Enterprise Manager, the following error is observed for one or more connected Domain Managers:

Distribution Status Error: Failure when opening the Container at the Domain. No order could be executed. Possible cause: Not enough disk space.

On the Domain Manager indicated, inside the TRC_USD_REPMAN_*.log (Replication Manager plugin), which is responsible for receiving and unpacking distributions from the Enterprise, the following trace, or similar, is observed:

INFO | D:\Program Files (x86)\CA\DSM\SD\ASM\D\EF47981C-D676-48F3-B994-CFDD6AF91BC1.in detected 
INFO | NotificationBase::send: sending... 
INFO | is a loopback 
INFO | No command line configured. Use dmzip.dll ZXPUncompress function 
INFO | Flags to ZXPUncompress : OVERWRITE | QUIETMODE | RELPATHS 
ERROR | Uncompress failure. ZXPUncompress error code: -4 
NOTIFY | ##EXCEPTION## TreeExpandError T@:commmisc\tree.cxx:1253. 
NOTIFY | ##EXCEPTION## TreeExpandError C@:DistL\distrec.cxx:411. 
NOTIFY | ##EXCEPTION## Expansion error: failure. ZXPUncompress error code: -4. 

Environment

Client Automation (ITCM) -- any version.

Cause

ITCM is not lying, the root cause for this particular error code is disk space.  See just below for an explanation...

Resolution

Short Answer:
When distributing software from the ITCM Enterprise, the Domain Manager will require three-times (3x) the amount of disk space, of the total size of all the packages contained in the distribution container.

Long Answer:
Software distributions are sent by the Enterprise using DTS (Data Transport System), to the Domain manager.  The payload, which contains all the software packages from the distribution container, is compressed into a single file and sent to the Domain Managers.

The Domain Manager receives the DTS file transfer at:
..\CA\DSM\dts\dta\staging\<transferID>

The transferID folder is a unique name, generated on the fly by DTS.

The DTS package is then decompressed, which in the case of an Enterprise distribution, will be another single compressed file.  It will be decompressed to:
..\CA\DSM\SD\ASM\D

The "D" folder is short for "Distribution", and this folder is checked periodically by the sdmgr_rm or software delivery replication manager plugin, for distribution files.  Once sdmgr_rm finds a file, the first step is to decompress it, within the same ASM\D folder.

Thus, momentarily, 3x the total size of the payload worth of free space is required to accommodate the distribution of the package, for extraction and storage on the domain manager.