CA Process Automation is unable to start ActiveMQ after numerous retries
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CA Process Automation is unable to start ActiveMQ after numerous retries

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Article ID: 115989

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager CA Process Automation Base

Issue/Introduction

CA Process Automation is unable to start ActiveMQ after numerous retries.

Error message in c2o.log:

ERROR [com.optinuity.c2o.c2oserver.ServerManager] [ Initialization] Unable to start ActiveMQ after numerous retries, hence shutting down the PAM server...

Environment

CA Process Automation 4.3.X

Cause

Somehow port 80 is being used and preventing ActiveMQ to start up properly.

Resolution

If it is a System Process PID 4, you need to disable the HTTP.sys driver which is started on demand by another service, such as Windows Remote Management or Print Spooler on Microsoft Windows.

Command to identify if Port 80 is in use:

netstat -ano | findstr ":80"

See example below:

Command to disable the HTTP.sys driver:

net stop http

If it does not work as expected (as the example above), you can disable http manually through Windows registry:

  • Launch RegEdit;
  • Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP;
  • Change the value of "start" to 4, which means disabled;
  • Reboot your computer.

Attachments

1558691477829000115989_sktwi1f5rjvs16gmj.png get_app
1558691475024000115989_sktwi1f5rjvs16gmi.png get_app