Can't start the Vertica database
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Can't start the Vertica database

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Article ID: 115858

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Can't start the Vertica database

After an OS patching cycle with the DB shut down before patching began, the DB will not restart.

DX NetOps Performance Management Data Repository database does not start following OS patching.

It shows all nodes as DOWN when checking the DB state via adminTools.

When trying to start it via adminTools we see the following error message.

Error: The vertica process for the database is running on the following hosts:
Node1_IP_Address
Node2_IP_Address
Node3_IP_Address
This may be because the process has not completed previous shutdown activities. Please wait and retry again.
Database start up failed. Processes still running.
Press RETURN to continue

Running "ps -aux | grep vertica" shows a still running Vertica process, like this example.

dradmin    6995  3.4 28.1 23290392 4569376 ?    Sl   May25 2835:46 /opt/vertica/bin/vertica -D /loddisk2/catalog/drdata/v_drdata_node0001_catalog -C drdata -n v_drdata_node0001 -h Node0001_IP -p 5433 -P 4803 -Y ipv4

Environment

All supported DX NetOps Performance Management releases

Cause

Hung Vertica processes

Resolution

There are hung vertica processes that must be killed before attempting to restart vertica. 

Do the following on each vertica node:

  • Simply do ps aux |grep vertica
  • kill -9 any running vertica processes
  • Restart vertica through adminTools

Vertica should now start successfully

Additional Information

Or use /opt/vertica/bin/admintools
Option 7 and 3

 

Continue with "YES"