Unable to view the alerts
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Unable to view the alerts

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Article ID: 115834

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Updated On:

Products

CA Workload Automation AE - Scheduler (AutoSys) Autosys Workload Automation

Issue/Introduction

The alerts does not show any jobs in WCC The monitoring views are not updating. The status shows 9 PM whereas the current time is 10 PM There is a error message that there are no active filters against the views.

Environment

Workload Automation AE 11.3.6 SP7 HA with single event server Oracle
WCC 11.4 sp6 HA with load balancing using Oracle database

Cause

Monitoring.log has the following error

2018-09-20 23:07:07,963 @monitoring <10.0.0.1 user123 ~799> [] ERROR EventResource Internal Exception: java.sql.SQLDataException: ORA-01843: not a valid month

 

Resolution

Stopped WCC services on both the WCC nodes
Started services only on one WCC node
To clear the bad data we refreshed the WCC database using " wcc_monitor  -u <username> -p <password> -d ALL"

 Now the views have number of jobs with status and the view status time is also updated But there are no jobs and alerts listed for the views in monitoring tab.

Collected the logs after server restart and we could see this error in monitoring logs

2018-09-21 02:29:10,366 @monitoring [] INFO BaseSpringFilter initialising context:/wcc/jsc-rest 2018-09-21 02:29:19,637 @monitoring <10.0.0.1 nologin> [] INFO PermissionFilter Access denied: invalid access session.

This is a privilege issue.
There was some recent change in the as-job policy.

 unchecking "Use Workload Automation AE polices in EEM" in monitoring preferences in WCC fixed problem.

Additional Information

For more details on the "Use Workload Automation AE polices in EEM"  feature please refer the following documentation

https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/workload-automation-ae-and-workload-control-center/11-3-6-SP8/ca-wcc-help-systems/ca-wcc-configuration-application/preferences-section-in-the-configuration-application.html