VSE Recorder using Proxy mode is not working
search cancel

VSE Recorder using Proxy mode is not working

book

Article ID: 115796

calendar_today

Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder) Service Virtualization

Issue/Introduction

Recording through proxy not working in DevTest.

Environment

All supported DevTest releases.

Cause

To be able to reach to the endpoint it is necessary to configure a proxy on the environment.

Without the proxy settings, the Workstation would time out and not be able to get to the endpoint.

Resolution

The following properties need to be configured in the Workstation local.properties file with the proxy information of your environment:

## ============================================== 
## HTTP Proxy Server 
## ============================================== 
lisa.http.webProxy.host=<MACHINE NAME OR IP ADDRESS> 
##list of excluded machine names or ip addresses delimited by pipes, * wildcard accepted <machine name or ip>[|<machine name or ip>]* 
#lisa.http.webProxy.nonProxyHosts=127.0.0.1 
lisa.http.webProxy.port=<PORT>

## ============================================== 
## HTTPS Proxy Server 
## ============================================== 
lisa.http.webProxy.ssl.host=<MACHINE NAME OR IP ADDRESS> 
##list of excluded machine names or ip addresses delimited by pipes, * wildcard accepted <machine name or ip>[|<machine name or ip>]* 
#lisa.http.webProxy.ssl.nonProxyHosts=127.0.0.1 
lisa.http.webProxy.ssl.port=<PORT>

The Workstation needs to be restarted after the local.properties file is updated.

Additional Information

If already have the proxy settings in the local.properties and is still facing issues to reach the endpoint, please refer the document in the link below:

local.properties is updated with proxy details but Workstation is not able to reach the endpoint