Cannot import environment zip file to the new environment
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Cannot import environment zip file to the new environment

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Article ID: 115750

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

During an Identity Manager upgrade process, to import environment.zip file from an old environment to a new Identity Manager version, from example, from CA Identity Manager 12.6 to 14.2, the error message is displayed.

"Error: The physical attribute "<attribute>" could not be found in the Identity Manager directory" 

Where <attribute> could be any user attribute, like manage, city, address, etc.

Environment

CA Identity Manager 14.x

Cause

The cause of this problem is the User Store was customized, I mean, new user attributes were added to the User Store, and it's needed to add those new attributes to the new User Store before trying to import the environment.zip file, and also check if some new attributes were added to the schema file.

Resolution

From CA Identity Manager Management Console, from an old environment, export the User Store xml file.

At this point, there are two possibilities:
1) Import the UserStore xml file to the new environment and update the current UserStore
2) Compare both UserStore xml files, from old and new environments.

In both cases, you need to check if new attributes were added to the UserStore schema, the files you need to check are located under folders:
- X:\...\CA\Directory\dxserver\config\servers
- X:\...\CA\Directory\dxserver\config\schema
- X:\...\CA\Directory\dxserver\config\settings
- X:\...\CA\Directory\dxserver\config\limits