QoS Post Policy Utilization Avg Metric shows incorrect data spikes
search cancel

QoS Post Policy Utilization Avg Metric shows incorrect data spikes

book

Article ID: 115502

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

cbQoS elements are showing spikes in data that don't correlate with real spike in device data or device usage.

QoS Post Policy Utilization Avg. % metric shows incorrect data spikes.

Environment

CA Performance Management releases r3.6 and earlier

Cause

Counter rollovers for 64bit counters.

Resolution

We had previously implemented a solution to resolve spikes for 32bit counters for the same cbQoS metrics. The same fix was implemented for the 64bit counters used here.

Engineering provided a fix and once in place the fix resolved the spiking data problems.

The solution is an update to the Cisco QoS ClassMap Certifications to use MVEL code to resolved spikes from counter rollovers in data calculations from snmpCounter64() functions.

This code only applies to CAPM r3.6 or higher and will be included in the r3.7 release.

Additional Information

Defect DE379778 resolves this with the initial r3.7.0 GA release.