Unable to clear specific alarm CONNECTION TO LANDSCAPE CANNOT BE ESTABLISHED
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Article ID: 115445
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Updated On:
Products
CA SpectrumDX NetOps
Issue/Introduction
We are unable to clear specific alarm "CONNECTION TO LANDSCAPE CANNOT BE ESTABLISHED Request to Landscape model failed due to an unknown error"
We also tried to clear the alarm by sending a clear code using VNMSH and getting connection not established error. We also tried restarting the SpectroSERVER, but this did not help.
Environment
Release: Any Component: SPCAEM
Cause
Landscape communication is handled by the Location Server process (locserv.exe) which is handled by parent process processd.exe. From time to time you may get a hang up on a process and requires a restart.
Resolution
1. Restart locserv.exe process. If <SPECROOT>/lib/SDPM/partlist/LOCSERV.idb is configure to have processd restart the process automatically (which is set by default) it should come back once killed.
2. Restart processd - in <SPECROOT>/lib/SDPM there is a script to stop/start processd:
processd.pl stop processd.pl start
Note: Restarting processd will bounce all child processes as well, and will shut down a running SpectroSERVER. It can be started back up once processd comes back up.