[AWA] newly installed Informatica Agent terminated immediately after start
search cancel

[AWA] newly installed Informatica Agent terminated immediately after start

book

Article ID: 115308

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

After installed a new RA Informatica Agent, it is not possible to start the agent, even the config, license & installation steps were correct.
  • RA Agent log:
U02013317 The RA Solution returned error code '0'.
U00003620 Routine 'UCEX_R' forces trace because of error.
...
U02000041 Shutdown Agent 'RA_INFORMATICA'.
           Agent Stopped
U02000010 Connection to Server 'x.x.x.x.:2217' terminated.
U02000002 Agent 'RA_INFORMATICA' version 'x.x' ended abnormally.
  • RA Agent trace:
java.lang.RuntimeException: Agent Definition data for pmcmd path is null. Edit the host table agent definition and save, then restart Agent.

 

Environment

Release:
Component: AAUTEN

Cause

A mandatory setting for Informatica agent has not been set on the Automation Engine

Resolution

  • Go to client 0, right click on the Informatica agent, and go to Informatica tab, then you can specify the path to"pmrep and pmcmd" directory.
  • Restart/Start RA Agent

Additional Information

Configuring the RA Informatica Agent Solution Agent