When logging into to Governance: A database error has occurred, contact the system administrator,production IG issue
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When logging into to Governance: A database error has occurred, contact the system administrator,production IG issue

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Article ID: 115157

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

The error on the screen, "A database error has occurred, contact the system administrator," indicates a problem with the back end database.

The logs also confirm a DB problem:

00:02:57,364 ERROR [com.eurekify.services.imservice.notifications.LiveNotificationsConsumerAbstract] (quartzScheduler_Worker-0) Error processing live notifications: org.springframework.dao.DataAccessResourceFailureException: could not execute query; nested exception is org.hibernate.exception.JDBCConnectionException: could not execute query...

Caused by: org.hibernate.exception.JDBCConnectionException: could not execute query
at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:97) [hibernate-core-3.3.1.GA.jar:3.3.1.GA]...

Caused by: java.sql.SQLRecoverableException: Closed Connection
at oracle.jdbc.driver.PhysicalConnection.prepareStatementInternal(PhysicalConnection.java:1631) [ojdbc8-12.2.0.1.jar:12.2.0.1.0]...

Error: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
at oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedStatement.java:932)...

Caused by: java.io.IOException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
at sun.nio.ch.SocketDispatcher.read0(Native Method) [rt.jar:1.8.0_171]...
 

Environment

Release:
Component: SGRM

Cause

The logs also confirm a DB problem:

00:02:57,364 ERROR [com.eurekify.services.imservice.notifications.LiveNotificationsConsumerAbstract] (quartzScheduler_Worker-0) Error processing live notifications: org.springframework.dao.DataAccessResourceFailureException: could not execute query; nested exception is org.hibernate.exception.JDBCConnectionException: could not execute query...

Caused by: org.hibernate.exception.JDBCConnectionException: could not execute query
at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:97) [hibernate-core-3.3.1.GA.jar:3.3.1.GA]...

Caused by: java.sql.SQLRecoverableException: Closed Connection
at oracle.jdbc.driver.PhysicalConnection.prepareStatementInternal(PhysicalConnection.java:1631) [ojdbc8-12.2.0.1.jar:12.2.0.1.0]...

Error: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
at oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedStatement.java:932)...

Caused by: java.io.IOException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
at sun.nio.ch.SocketDispatcher.read0(Native Method) [rt.jar:1.8.0_171]...

 

Resolution

In the above scenario, an  external IP address (through a VPN) of the sigma database was unstable. This issue was resolved after changing the external IP address of the database to the local/internal IP address of the data source in the SIGMA standalone*.xml.

Your issue may be due to another database problem.

Please contact your database administrator with the above errors from the logs so they can investigate and fix the cause of the database not responding.