Identity Portal stopped working on R14.2 Vapp after migrated
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Article ID: 113793
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Updated On:
Products
CA Identity ManagerCA Identity GovernanceCA Identity Portal
Issue/Introduction
After migrating IM from R12.6 SP4 to Vapp R14.2, IP stopped working. IP dashboard showed: IP User Console is not available (Main Connector is down or not defined)
Environment
IDS vApp r14.2.0 with IP and IM.
Cause
Reviewing IDM wildfly server log shows that IM is properly started. (---- CA IAM FW Startup Sequence Complete. ----).
About IP it was up at 11:07:00,849 (JBAS015874: WildFly 8.2.0.Final "Tweek" started). Then IP started to fail at 11:07:03 trying to launch the IM connector. It failed to reach (Rest API) URL: http://caim-srv:80/iam/im/ws/identityEnv/portal/sync to GET data in json format. The Payload returned was: {"errorCode":"999","errorLiteral":"INTERNAL_SERVER_ERROR","message":"Internal server error"}
At the same time on IDM wildfly server log it failed as following: 2018-09-11 11:07:03,056 ERROR [iamframework.webservices] (default task-35) Failed to create web services configuration.: NotAuthorizedException: Administrator imadmin is not authorized to perform task Modify Web Services Configuration.
Resolution
"imadmin" was member of "System Manager" admin role as expected. From IM User Console, Added the "Modify Web Services Configuration" admin task into the tasks list of the "System Manager" admin role.