Request Failed message when logging into Identity Portal
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Request Failed message when logging into Identity Portal

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Article ID: 113764

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

"Request Failed" when logging into /sigma/app/index#

Environment

Release:
Component: SIGMA

Cause

This is  a problem with the configuration of the SSO agent.

For example, the problem is in the call for "https://portal_URL.com/sigma/rest/resources/USERPIC/iibgw.jpg". This call fetches the user image. It is responded with 401 (unauthorized) because this directory is protected.

Resolution


Please refer to the page "Protecting CA Identity Portal with CA Single Sign-On" in the product documentation and make sure the configuration matches what it describes:

Single Sign-On Authentication using Symantec SiteMinder

Pay special attention to Configure Agent Configuration Object details.   "/sigma/rest/resources" realm should be protected and the Agent Configuration Object must have the exact same IgnoreExt as in the documentation - ".class,.fcc,.scc,.sfcc,.ccc,.ntc,.css,.js,.woff,.woff2,.svg,.ttf,.eot,.json",
Ensure that "jpg" is not on that list.

This should solve this issue