API Portal: Scheduled Tasks for Portal Sync Are Not Running on Gateway
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Article ID: 113761
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Updated On:
Products
CA API Developer PortalCA API Gateway
Issue/Introduction
When viewing the Proxy sync status in API Portal, sync appears with the red X next to it or otherwise appears out of date with the time it shows the last sync was performed.
When reviewing the Audit Event Viewer on the API Gateway cluster associated with the API Portal, either none of the scheduled tasks are running or some of the scheduled tasks are not running.
These scheduled tasks are important to the function of the API Portal as they are syncing mechanisms to provide data from the API Gateway to the API Portal.
In some cases, if synchronization-related scheduled tasks are not running, authentication can fail to APIs using an Application Key and Secret, providing an HTTP 401 error with "Invalid Credentials".
Environment
API Portal 4.2.x.
API Gateway 9.2.00 CR05 and newer
Cause
The user assigned to the scheduled task (to execute it) was removed from the identity provider, whether it be internal or over LDAP.
Resolution
Edit the Scheduled Tasks and change the user assigned to it to be another user with administrative privileges in Policy Manager.
If the Scheduled Task cannot be edited (this sometimes happens depending on the version of Policy Manager and CR used on the Gateway), it is best to re-create them and then remove the old non-working scheduled tasks with the Portal sync capabilities.
Additional Information
The user signed in to Policy Manager to do the initial enrollment process is the user automatically chosen to execute the scheduled tasks brought down / created during the enrollment process or bundle installation. It is recommended that a dedicated Portal user be used for enrollment, assigned with administrative privileges, in order to decrease chances in the future of the user being removed from the identity provider.