Servers are not properly synchronized between CA Spectrum and CA Performance Management
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Servers are not properly synchronized between CA Spectrum and CA Performance Management

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Article ID: 113760

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

CA Performance Management (CAPM) and CA Spectrum are integrated together via the Default Domain.

Some Servers synchronized via the integration are showing normally as Servers after discovery in the Data Aggregator.

Some Servers synchronized via the integration are showing as 'Other' and show no polled data from the Data Aggregator.

Environment

All supported CA Performance Management releases

Cause

Working Servers are present in the Default Domain Global Collection as members one time.

Non-working Servers are present in the Default Domain Global Collection as members twice and are duplicates.
Some are present from each of two landscapes in the environment, one per landscape.
Same are present with both models discovered on the same landscape.

The duplicates contributed to the integration is breaking the Data Aggregator's ability to complete the integrations processing of the device.

Resolution

Correct resolution involves cleaning up the duplicate models discovered in the Spectrum environment. There should not be duplicates discovered in Spectrum.

To resolve this and get the items resynced via the integration to allow it to do the work for us:
  1. Remove the devices that have duplicate models discovered in Spectrum from the Default Domain GC.
  2. Clean up the duplicates in Spectrum by deleting one or the other.
  3. Confirm the devices are gone from CAPC inventory after a Spectrum and Global sync pass.
  4. Add the devices back into the Default Domain Global Collection.

Once they sync back to CAPC we should see this progression:
  1. They show up in the CAPC Inventory contributed only by Spectrum.
  2. IPs show up in the Default Domain Discovery Profile.
  3. When that Profile runs, or is run manually/on-demand, if discovery is successful the problem servers will show up as working server types same as existing working samples.

Additional Information

Alternative solution: Ensure Default Domain Global Collection contains a single model for each that has a duplicate discovered in the Spectrum environment.