search cancel

Live service invocation failure: ConnectException: Connection refused: connect 

book

Article ID: 113729

calendar_today

Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder) Service Virtualization

Issue/Introduction

When verifying the VSM in DevTest Workstation, getting the following error:

| Unable to connect to <LiveHost>:8443. 
============================================================================ 
| Step: Virtual HTTPS Live Invocation 8443 
---------------------------------------------------------------------------- 
| Message: Connection refused: connect 
---------------------------------------------------------------------------- 
| Trapped Exception: Connection refused: connect 
| Trapped Message: java.net.ConnectException: Connection refused: connect 
---------------------------------------------------------------------------- 
STACK TRACE 
java.net.ConnectException: Connection refused: connect 
at java.net.TwoStacksPlainSocketImpl.socketConnect(Native Method) 
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) 
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) 
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) 
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) 
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) 
at java.net.Socket.connect(Socket.java:589) 

Environment

All supported DevTest releases.

Cause

Network issue.  The Live Host and Port cannot be connected to from the Workstation machine outside of DevTest.

Resolution

Network team needs to be contacted to resolve..