CORBA::COMM_FAILURE error seen in the Spectrum VNM.OUT and ARCHMGR.OUT files
search cancel

CORBA::COMM_FAILURE error seen in the Spectrum VNM.OUT and ARCHMGR.OUT files

book

Article ID: 113726

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

The following errors are see in the $SPECROOT/SS/VNM.OUT and $SPECROOT/SS/DDM/ARCHMGR.OUT file:

ERROR TRACE at CsCorbaMgr.cc(864): Exception: CORBA::COMM_FAILURE

Environment

Any Spectrum version

Cause

Check the contents of the landscape map for an incorrect entry by doing the following:

1. Log into the SpectroSERVER system as the user that owns the Spectrum installation

2. If on Windows, start a bash shell by running "bash -login"

3. cd to the $SPECROOT/SS-Tools directory and enter the following command:

./MapUpdate -v

Resolution

If an incorrect entry is seen, this needs to be removed using MapUpdate with the "-remove" parameter.

Reference the "MapUpdate" section of the documentation for details
 

Additional Information

The most likely reason for the incorrect entry is if you are running two different Spectrum environments, a landscape from the other environment got added to the landscape map.

To prevent this, lock down the $SPECROOT/.hostrc files in the environments to include only the hostnames/ip address of the SpectroSERVER, OneClick and SRM systems for that environment. Do not use the plus "+" character.