[AWA] User cannot be deleted because of active tasks
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Article ID: 113623
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Updated On:
Products
CA Automic Workload Automation - Automation EngineCA Automic One Automation
Issue/Introduction
On Automic Workload Automation, when deleting old users, the following error appears:
Therefore the users are unable to be deleted.
Environment
Release: Component: AAUTEN
Cause
- There are not-deactivated tasks by that user.
Resolution
Common solution:
Go to client on which you wish to remove the user > open Process Monitoring Perspective > Filter > Time Frame: select the suitable time range & User Object: select the user that you want to remove
Click the Filter button (leaving option Include deactivated tasks unchecked) > then you should see the tasks that are still active under that particular user
Cleaning the tasks that are not deactivated then remove the user.
The following SQL can be run to determine the client where the tasks are located, and the runID of the tasks so they can be more easily searched for in AWI: select * from eh where EH_USR_Idnr in (select oh_idnr from oh where oh_name = 'AUTOMIC/AUTOMIC') ---- make sure to change the user/dept
Workaround that can be applied in case it is still not working:
Option 1: Disable/Rename the user can help prevent the security risks while still being able to keep the statistics of that user.
Option 2: Use SQL query to search and deactivate tasks under the execution of that user and then delete it (please contact Customer Support for SQL queries)