Error SARDBI04 occurs during SARDBASE RENAME
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Error SARDBI04 occurs during SARDBASE RENAME

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Article ID: 113621

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Updated On:

Products

Deliver View

Issue/Introduction

A client's attempt to rename a View database, with SARDBASE RENAME, failed with error:
SARDBI04 Data set rename failed - REQ=RENAME RC=0008 REASON=04100800

Environment

Release: OUTDTI00200-14.0-Deliver-Output Management-Interface for Native TSO
Component:

Cause

SARDBASE renames all data sets for the database.
The message SARDBI04 Data set rename failed - REQ=RENAME RC=0008 REASON=04100800 means that you have insufficient authority to ALTER the dataset.
Check the job sysout for any message IGD17061I INSUFFICIENT SECURITY AUTHORIZATION. Return code is 8; DIAGNOSTIC INFORMATION IS 04100800
The code 04100800 is issued when trying to rename the database, and the request is rejected.
If you have the authority to uncatalog the dataset, but not the authority to rename it or catalog it, this can happen. This is expected.

Non-SMS datasets may be uncataloged when you try to rename them and do not have sufficient authority.
This is not a CA View problem.

Resolution

You have to give SAF (RACF) authority to the user trying to rename the database file.

Additional Information

Please see doc:
https://docops.ca.com/ca-view-messages/en/messages-and-abend-codes/system-error-messages/sardba-to-sardbm-system-error-messages/sardbi03-through-sardbi10