search cancel

ServiceDeskIntegrationSetup utility does not accept users with special characters

book

Article ID: 113583

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

If you provide a username with any special characters, you will get a message similar to the below:

----- Service Desk Integration Setup -----
-
-  OneClick server information must
- be gathered in order to enable the
- integration with Service Desk.
-
-   OneClick Server name?> Server1
-   OneClick Server port?> 8080
-   OneClick Homepage path [default="spectrum"]?> spectrum
-   Username?> ca_discov
-     *** Error: Invalid user name. ***

 

Environment

Spectrum 10.2.x
Spectrum 10.3

Cause

The ServiceDeskIntegrationSetup utility does not accept users with special characters.

Resolution

This problem was already mapped, and a fix will be included in the next CA Spectrum version.

As a workaround, the following procedure can be done:

1- Run the utility again, with any username, and provide the password of the desired user.

2- After that, you just need to change the username to the desired one, in the <Service_Desk_Installation_directory>/bin/oc-integration.cfg file, located in the Service Desk server.