search cancel

IT Access Services (Security Team) is getting RS256E error messages via RC/Secure Application Domain

book

Article ID: 113579

calendar_today

Updated On:

Products

RC Compare for DB2 for z/OS Database Analyzer for DB2 for z/OS Fast Unload for DB2 for z/OS Fast Check for DB2 for z/OS Fast Index for DB2 for z/OS Rapid Reorg for DB2 for z/OS

Issue/Introduction

IT Access Services (Security Team) is getting RS256E error messages via RC/Secure Application Domain We have upgraded CA-DB2TOOLS R18 to R19 in the development environment and is currently experiencing RS256E error messages when trying to add an Object in the RC/Secure Application Domain. 

Environment

z/os DB2

Cause

There are no new requirements/changes between R18 and R19 that affect how Dept (Not-Used) is used

Resolution

1) There are no new requirements/changes between R18 and R19 that affect how Dept (Not-Used) is used.
2) The likely cause of the error RS256 is when there is no entry for the object type in the PTRCS_DPTDEF_0200 table. To confirm this on our system, we have deleted all the wildcard entries (VALUES('*','*',' ','*','DB',USER,CURRENT DATE,'G', '*', '*')) and tried to add a DB object as you have and we can see the error RS256.
Once we added the DB entry with the above values to the PTRCS_DPTDEF_0200 table, we are able to add the object.
So the possible cause we think of this is that there were SQL errors while fetching the data from the table.
Did you face any errors other than RS256 ?
If needed, you can delete the recent entry and see if you are facing this issue again.