SDM becomes slow or unresponsive with corrupted allocator errors in stdlogs
search cancel

SDM becomes slow or unresponsive with corrupted allocator errors in stdlogs

book

Article ID: 113519

calendar_today

Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

The following error messages are flooding the stdlogs and SDM experiences performance issues or becomes inaccessible until server is restarted:

spelsrvr SEVERE_ERROR allocator.c 527 Allocator BPData free chain pointer 078913A8 references a corrupted allocator

Environment

SDM 12.9, 14.1, 17.x

Cause

The root cause of the problem has been found to be with the internal memory allocators.

Resolution

The correction for this problem, beginning in 14.1 cumulative patch 4, introduces two new NX variables - NX_SPEL_DISABLE_ALLOC and NX_MAIL_DISABLE_ALLOC - which when set to 1, will disable the internal allocators in spelsrvr and pdm_mail_nxd processes respectively. The following steps can be followed to install the options in a conventional configuration:

a. These options can be installed by running the following command 
from the Command Prompt on the Primary server machine: 

"pdm_options_mgr -c -s SPEL_DISABLE_ALLOC -v 1 -a pdm_option.inst" 

"pdm_options_mgr -c -s MAIL_DISABLE_ALLOC -v 1 -a pdm_option.inst" 

b. To avoid losing the change when you run pdm_configure, please 
run the above command with the '-t' flag as follows: 

"pdm_options_mgr -c -s SPEL_DISABLE_ALLOC -v 1 -a pdm_option.inst -t" 

"pdm_options_mgr -c -s MAIL_DISABLE_ALLOC -v 1 -a pdm_option.inst -t"