admin tasks fail to execute after patching
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admin tasks fail to execute after patching

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Article ID: 113433

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

After deploying a Identity Manager Suite 12.6.8 cumulative patch (see product documentation for more information on cumulative patches) some admin tasks fail to execute. 
https://docops.ca.com/ca-identity-manager/12-6-8/EN/release-information/release-notes-12-6-08-cr1-cumulative-patches

Environment

Identity Manager Suite 12.6.8

Scenario:
An admin task that has an approval task There is a user attribute called IP_ADDRESS During the execution of the admin task this attribute has the literal string value of "ADD" At the approval task, a user will set this to an actual IPv4 address (e.g. xxx.xxx.x.xx) After the task completes this user attribute (the actual IP address) will be reflected in the user's profile. A PX that is triggered when that admin task completes, the PX will inspect the value of the IP_ADDRESS attribute

Before the patch, when it inspects the value, it will see the actual IP address (e.g. xxx.xxx.x.xx) After the patch, when it inspects the value, it sees the literal string "ADD"

Cause

This issue is caused by cached results stored in JBoss failing to parse as expected.

Resolution

Clearing the standalone/tmp folder (i.e. C:\JBoss\EAP\6.4.0\IDM\standalone\tmp\) corrects this issue and and the expected behavior is restored.