When attempting the integration of Process Automation with Service Desk using the main installer it fails
search cancel

When attempting the integration of Process Automation with Service Desk using the main installer it fails

book

Article ID: 113349

calendar_today

Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When attempting to integration Process Automation (ITPAM) with Service Desk (SD) using the main installer it fails and the install.log file captures the error bellow:

PAMProcessImporter] Loading PAM Process for SDM
DEBUG [DeployThread: Integración de los productos] [PAMProcessImporter] [https:, , servername or FQDN, itpam, soap]
ERROR [DeployThread: Integración de los productos] [PAMProcessImporter] Exception while loading PAM Process for SDM
ERROR [DeployThread: Integración de los productos] [PAMProcessImporter] [Ljava.lang.StackTraceElement;@1606140
INFO [DeployThread: Integración de los productos] [IntegrateSDMWithPAM] Importing Process Automation Sample Process returned with exitCode: -1

Environment

Service Desk 14.1 or above
ITPAM 4.3 or above

Cause

Cause 1:
The import of the sample process failed, since this part of the procedure does not include a retry it will failed directly and will prompt the error message, this could be caused by a connectivity issue at the given time of the integration.

Cause 2:
This issue will also occur if the PAM URL does not include the port, specifically for the samples of ITPAM the installer only recognizes hostname:port URLs. 

Resolution

Solution 1:
Ensure that the network communication with the ITPAM server and SD server work properly during the installation and so on.

Solution 2:

1. Identify what you have in the DB:
SELECT * FROM [mdb].[dbo].[al_cdb_configurationparameters]
WHERE configvalue like '%itpam%'

2. The results should show the URLs in the format: https://server_name or FQDN/itpam/soap
3. Update these to have your port number so to something like: https://server_name:port/itpam/soap
4. Retry the installation process.