System Agent occasionally reports unqualified
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System Agent occasionally reports unqualified

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Article ID: 113127

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Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent

Issue/Introduction

System agent is reporting as unqualified on occasion.

Environment

Release:
Component: SYSAGT

Cause

The agent configuration may be trying to converse with another scheduler in which the network ports are not available. The agent continuously makes an attempt to reach the scheduler and as a result may begin to encounter communication issues with another valid scheduler.

Resolution

  1. Ensure that the agent is not defined in the environment where the communication errors are being reported. Enter the command autorep -M <agent_name>. If the agent were to remain defined in the scheduler, the scheduler would eventually push down it's communication settings and it would attempt to communicate again. 
  2. As a result of the above autorep command, if the agent is still defined, you will see a response indicating as such. To remove it, issue the command autorep -M <agent_name> -q | grep insert > agent.jil. This will produce a file called agent.jil for you to edit. 
  3. Now that you have the JIL file for the agent, you will need to edit it to delete the machine from the AutoSys database. Open the file using the vi editor and change the insert_machine to delete_machine and save the file. 
  4. Finally, delete the machine by entering the command jil < agent.jil. You should see a response indicating the agent machine was deleted. 
  5. At this point, the agent is no longer defined to the scheduler, so now delete or comment out the Sandbox scheduler references in the agent's agentparm.txt file.  
  6. Save the file and recycle the agent service.