Spectrum Docker containers stopped with 'exited' status
search cancel

Spectrum Docker containers stopped with 'exited' status

book

Article ID: 113019

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

Spectrum Docker containers stopped with 'exited' status

Upon issuing command:

docker ps -a

Returns this:

CONTAINER ID        IMAGE                    COMMAND             CREATED             STATUS                    PORTS               NAMES
ae368381adc7        spectrum-srm-image-103   "/dispatcher.sh"    4 days ago          Exited (137) 3 days ago                       brave_hopper
3bc3688ea1e8        spectrum-ss-image-103    "/dispatcher.sh"    4 days ago          Exited (137) 3 days ago                       eloquent_ptolemy
b7fba2522377        spectrum-ss-image-103    "/dispatcher.sh"    4 days ago          Exited (130) 4 days ago                       goofy_hawking

Environment

Release: Any version of Spectrum
Component:

Cause

This can be caused by a container being stopped abruptly.

If you were running a container in a bash shell and then control + C or lost connection - this would cause this issue.

Resolution

To start these containers backup, issue the following command:

docker start $(docker ps -a -q --filter "status=exited")

You will then have to connect to the container and fix the SSdb since the SpectroSERVER stopped ungracefully as well.

Reference "The SpectroSERVER fails to start after restoring the SSdb Database from a known good backup."

Once that is resolved, you can start the SS backup normally.

Reference "How to start SpectroSERVER after running a Docker Container installation?"

Additional Information

A docker container should be treated like any physical or virtual machine.

Be sure to shutdown all Spectrum Applications before shutting down the container.