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Timeout exceptions during Live Invocation execution mode

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Article ID: 113002

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Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder)

Issue/Introduction

Forwarding requests to the live system via Live Invocation execution mode is not working properly.
The Inspection View shows Timeout exceptions with the Live Invocation step.

Cause

When sending a request to the VSM running in Live Invocation mode in the VSE Server, there is no response.
If the VSM is executed in the ITR, a response from the live system is returned with no issues.
When looking at the Inspection View, there were few errors with this VSM in the Live Invocation step. It was a timeout to connect to the live server in the specified port.
From the VSE Server, it was able to verify we were able to ping the live server but not able to telnet the live server on the specific port.

The issue is caused because the VSE is not able to connect to the live server in the port the live service is running.

Environment

All supported DevTest releases.

Resolution

Verify with the network team what is preventing the connectivity from the VSE server to the live system address.
To test the connectivity we can use:
#telnet serverAddress portNumber

Once we are able to connect to the Live Server from the VSE server, the VSM should work without issues when in Live Invocation mode.

Additional Information

More information regarding Execution Modes: Execution Mode