Intermittent Request Failure with status 101 in cluster environment
book
Article ID: 112990
calendar_today
Updated On:
Products
CA Service CatalogCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
Intermittent Request Failure with status 101 in cluster environment
Environment
catalog 17.1 ro catalog 17.1 with rollup1 patch
Cause
Customers who upgraded to 17.1 from previous versions and having cluster environment (more than one node, it can be via load balancing…etc.), they may encounter “request not getting submitted” issue with below error: com.microsoft.sqlserver.jdbc.SQLServerException: Violation of PRIMARY KEY constraint 'XPKusm_subscription_detail'. Cannot insert duplicate key in object 'dbo.usm_subscription_detail'. The duplicate key value is (51739). at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:217) at com.microsoft.sqlserver.jdbc.SQLServerStatement.getNextResult(SQLServerStatement.java:1635)
Here even they submitted request it will be in “Not-submitted” state (101) This is an Intermittent issue. If they re-start all the nodes issue will get resolve.
You may also see key constraint errors on other tables such as: 2019/04/15 11.58.57.279 ERROR [Rule Action Executor-3] [Util] UTIL0101 com.microsoft.sqlserver.jdbc.SQLServerException: Violation of PRIMARY KEY constraint 'XPKusm_system_alert'. Cannot insert duplicate key in object 'dbo.usm_system_alert'. The duplicate key value is (100000).
Resolution
It is a bug , which is addressed by the testfix T6D9388 ( Its pre-requisites are 17.1 Rollup1 + T6D9385 ) . You can contact CA support via support case to get T6D9385 and T6D9388 .
Both T6D9385 and T6D9388 will be rolled into next rollup patch : 17.1 rollup2 ( which will be published and available to download Nov 2018 )
For 14.1, this is also addressed by t6d9406 on top of cp5 and ru1