Special Day not accounted for in schedule
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Special Day not accounted for in schedule

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Article ID: 112984

calendar_today

Updated On:

Products

DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

We have a Date-Time/Manual event with the following schedule:

Schedule    5PM weekdays except XXXXXXX
Schedule    12PM weekends except XXXXXXX
Schedule    7AM XXXXXXX

The XXXXXXX is a special day that we define in the calendar as needed. When a XXXXXXX date is encountered, however, the event ignores it and uses the normal schedule. Since this did work in test, we did some research and found that (1) the next trigger date/time is embedded within the event and (2) the event is not updated when the new XXXXXXX special day is defined.  Is this the way CA Workload should behave, and if so is there another way to implement this type of schedule?

Environment

Release:
Component: DSRIES

Cause

The special day was added after the event had already been scheduled. In doing so, the special day is not re-read in to account for the new date conditions.

Resolution

If you did not define the dates for XXXXXXX before the time the last event was triggered, it will not run as you expect in the future. If you know the dates which should be defined in the XXXXXXX special day, then you should have them added ahead of time. The calendar is not read after the calendar has been set unless you re-upload the event to DE.