UIM Alarms not Appearing in Spectrum Using the spectrumgtw probe for the integration
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UIM Alarms not Appearing in Spectrum Using the spectrumgtw probe for the integration

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Article ID: 112676

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

The spectrumgtw probe is successfully connected to the configured Spectrum OneClick (OC), and appears to be successfully executing REST API calls, but no UIM alarms appear in Spectrum.

From the spectrumgtw.log file at loglevel 5 we see errors similar to the following when the spectrumgtw probe attempts to create alarms in Spectrum:

[twScheduler_Worker-7] ERROR SpectrumAlarmProducer - Alarm creation failed in Spectrum for event id  Removing alarm NP21757771-87376 from UimAlarmsCache

Environment

  • UIM/UMP: 8.51
  • spectrumgtw: 8.65
  • Spectrum: 10.2.3

Cause

  • The hex handle of the SpectroServer was configured in the Spectrum Selected Landscape field of the UIM Configuration section on the spectrumgtw probe's Configuration page.

Resolution

  1. Replace the hex handle in the Spectrum Selected Landscape field of the UIM Configuration section on the spectrumgtw probe's Configuration page
  2. Save the change
  3. Cold start (deactivate, then activate) the spectrumgtw probe