Dx NetOps Portal log in page returns HTTP 500 error
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Dx NetOps Portal log in page returns HTTP 500 error

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Article ID: 112600

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Updated On:

Products

CA Infrastructure Management CA Performance Management

Issue/Introduction

The Dx NetOps Performance Management, Dx NetOps Portal web server UI is returning http 500 errors when attempting to log in. It was previously functioning normally and this error appears suddenly and unexpectedly.

The error continues after restarting the Dx NetOps Portal services.

Environment

All supported Dx NetOps Performance Management releases

Cause

The Dx NetOps Portal servers /tmp/ribcache directory is consuming all available space in the /tmp directory.

Resolution

The /tmp/ribcache directory on a Dx NetOps Portal server contains RIB documents downloaded from the  Data Aggregator (DA). They are used to provide faster RIB call responses during normal Dx NetOps Portal operation.

These are meant to be temporary but some instances have shown them causing a disk space issue in the /tmp directory.

Dx NetOps Portal requires 4GB of space in /tmp for normal operation.

To resolve this:

  1. Stop the Dx NetOps Portal services.
  2. Delete all files within the /tmp/ribcache directory.
  3. Start the Dx NetOps Portal services.


Use Knowledge Base Article ID kb000032043 for Dx NetOps Portal Service stop and start instructions.

Additional Information

Note that when the Dx NetOps Portal services start after deleting the /tmp/ribcache, they will download the Data Aggregator RIB documents into /tmp/ribcache.

Initially it will take longer for Dx NetOps Portal to complete RIB calls against the DA.

Once the RIB documents have been fully downloaded, the next restart of Dx NetOps Portal services will allow DA RIB calls sooner since the RIB docs will be in the cache.