search cancel

When Emailing Knowledge Documents as HTML, images from KB document are not included in the email.

book

Article ID: 112577

calendar_today

Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When analysts try to email knowledge documents to users as HTML documents, the images are dropped out from the document that is sent.

Cause

JavaScript restrictions blocking images in the email.

Environment

SDM 17.1

Resolution

Gmail is known to block JavaScript, however sending the same email to an Exchange account may block the image but will give an option to download it.

"Click here to download pictures. To help protect your privacy, Outlook prevented automatic download of some pictures in this message"

Unfortunately if the email client is set to block JavaScript there are no known workarounds at this time as this must be used when emailing HTML Knowledge Documents.