SUPPORT AUTOMATION- SERVERCA Service Desk Manager - Unified Self ServiceCA Service Desk ManagerCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
On the production 14.1.04 environment, the Archive and Purge Rule Detail page (detail_arcpur_rule.htmpl) displays oddly, with all of the text squished over to the right side of the frame on a gray background. When clicking Edit, the Configuration Object Name dropdown only displays a "?" character, and no other values can be selected.
Environment
CA Service Desk 14.1 CP4, AA environment
Cause
Issue may present when using one of the given servers in the AA as the Background Server. Potential cause is the @NX_DOMSRVR_NAME listing in NX.env being set to a specific server name, ie: @NX_DOMSRVR_NAME=SERVER1.
In the running example for archive/purge, the archive purge daemon is unable to connect to the assigned domsrvr, per the above variable setting.
Resolution
Change @NX_DOMSRVR_NAME=SERVER1 to be set as "ANY", ie: @NX_DOMSRVR_NAME=ANY
One should also compare NX.env settings across the BG/Background and SB/Standby Servers