Some monitors no longer work after maintenance in ESXi server
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Some monitors no longer work after maintenance in ESXi server

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Article ID: 112518

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After some maintenance work performed in ESXi server side, monitors for ESXi server (such as "VMCount") no longer work.
It was working before ESXi server side maintenance.

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Environment

vmware probe ANY version.
Static monitor (Not auto monitor) is used.

Cause

VMware ESXi Host's UUID was changed by the maintenance.
Since static monitor uses internal ID to track object, it does no longer work after the internal ID is changed.

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Resolution

1. Delete old (invalid) monitors from vmware probe.
2. Deactivate vmware probe.
3. Activate vmware probe.
4. Create monitors manually again.
 

Additional Information

1. This is how to confirm ESXi server HOST's UUID.

https://<host>/mob/?moid=ha%2dhost&doPath=hardware%2esystemInfo
Where <host> is your ESXi server host's IP, shortname or FQDN.

2. You may want to consider using "Auto Montior" rather than "Static Monitor"
Auto Monitor does not use an internal ID to track object.
Please take a look at the below KB to understand advantages and disadvantages of Auto Monitor.

What is difference in between 'Static Monitor' and 'Auto Monitor' and how IM GUI 'Template' interacts with probe.
https://comm.support.ca.com/kb/What-is-difference-in-between-Static-Monitor-and-Auto-Monitor-and-how-IM-GUI-Template-interacts-with-probe/kb000010355

Attachments

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