A lot of ncmconfigbucket files under ./data/reporting

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Article ID: 112509

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Updated On:

Products

CA Spectrum

Issue/Introduction

Customer sees for OC-Server install under $SPECROOT/mysql/data/reporting a very high number of "ncmconfigbucket*" files. These are aged and the number is constantly increasing.

It appears the bucket*-table logic to read the bucket-files and to process the data putting them into the primary "reporting" database table is not working especially for the "ncmconfigbucket*" tables. CA Spectrum is implemented with many other "bucket"-tables too - the processing for those others are all fine. So seeing only the "ncmconfigbucket*" files are increasing and never cleared/processed.

 

Cause

Internal OC-ReportManager "ncmconfigbucket*" processing failure.

 

Environment

Spectrum configured with Spectrum Report Manager.

 

Resolution

This issue has been addressed in the following Spectrum patches:

The 10.02.03.D429 patch is available and requires Spectrum 10.2.3 and the BMP_10.2.301 be installed first. 

The 10.03.00.BMP_10.3.001 patch is available and requires the installation of Spectrum 10.3 be installed first.

The fix will also be included in the 10.02.03.BMP_10.2.303 patch when released. No projected release date at the time of the publishing of this knowledge document.

Please contact Spectrum Support for a copy of patch to install in your Spectrum environment.

 

Additional Information

There is no patch available for Spectrum 10.2.2 and below. However, the following steps can be done to address the issue: 

For example, if the oldest ncm bucket file is April 1, 2019, then you would do the following: 

1. Shutdown tomcat on the SRM system 

2. If on Windows, start a bash shell by running "bash -login" 

3. cd tot he $SPECROOT/mysql/bin directory and enter the following command to log into mysql: 

./mysql --defaults-file=../my-spectrum.cnf -uroot -proot reporting 

4. Enter the following command at the mysql prompt: 

delete from bucketactivitylog where bucket_table_name like '%ncm%' and creation_time > '2019-04-01 00:00:00'; 

5. Log out of mysql 

6. Remove the ncm bucket files from the $SPECROOT/mysql/data/reporting directory 

7. Restart tomcat on the SRM system

NOTE: When following these steps, there will be a gap in the NCM reporting.