Fatal Error during Agent deployment
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Fatal Error during Agent deployment

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Article ID: 112341

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Updated On:

Products

CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

When an upgrade is being made using Deployment Wizard, the deployment job ends with error "Error irrecuperable durante la instalaciĆ³n" (translated as "Fatal error during installation"):


Environment

Client Automation 14.0 and above

Cause

This error message is not an ITCM error, but is what the target OS returned when it tried to run the Agent installation package. This means that the package has a problem within its code which is the reason why it's failing.

Resolution

Under certain circumstances, when ITCM's ISO is copied or moved, there may be problems with the files in it.
In order to solve this, it's recommended to download again the ISO (verifying md5 value) and load again the needed packages into Infrastructure Deployment Wizard using 'dsmpush' tool, as explained here:

https://docops.ca.com/ca-client-automation/14-0/en/reference/cli-command-reference/dsmpush-push-ca-client-automation-component-installation-packages-to-domain-manager