Port 8282 Listening On Agent Machine After Disabling JMX
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Article ID: 112334
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Updated On:
Products
CA Release Automation - Release Operations Center (Nolio)CA Release Automation - DataManagement Server (Nolio)
Issue/Introduction
We are having an issue where we are trying to shut down port 8282 on one of our servers that has a CA Release Automation Agent installed. So far, we have set the following in the nolio.jmx.properties: DeployerJmxPort=0 DeployerJmxEnabled=false
But after restarting the agent we see that it is still listening on port 8282.
Environment
CA Release Automation 6.x Agent on Windows Server.
Cause
There was no CR/LF between the DeployerJmxPort=0 and DeployerJmxEnabled lines. Windows servers need a CR/LF between lines in order for it to be picked up as a new line.
Resolution
Edit the file in windows (to insert a CR/LF between the two lines), save the file, stop and restart the agent.