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Open Workbench access via Reverse proxy
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Article ID: 112261
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Updated On:
Products
Clarity PPM On PremiseClarity PPM SaaS
Issue/Introduction
When using Open Workbench via reverse proxy, Save and save As function might fail.
Checking the access.log files we might find the session ID is missing on the POST request:
Access log without reverse proxy There is session id at the end of URL. xx.xx.xx.xx|[07Aug/2018:18:16:15 +0900]POST /niku/app?buildVersion=800 &post=true&action=schedulers.GetSavePrecheckRequest&externalSource=CA+PPM+Workbench &version=117440512 HTTP/1.1|200|44|46|5903078__ED49B438-0A57-4084-90F8-A4BEA66F8AB9
Access log with reverse proxy There is no session id at the end of URL xx.xx.xx.xx|[07Aug/2018:18:13:36 +0900]POST /niku/app?buildVersion=800 &post=true&action=schedulers.GetSavePrecheckRequest&externalSource=CA+PPM+Workbench &version=117440512 HTTP/1.1|200|59|18|
Cause
PPM needs to use the same session (Sticky Session) in a multi server environment. Open Workbench also requires Sticky Session.