SPC-OCA-10360: Connection lost. Either the server is not running or a network problem is preventing access
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SPC-OCA-10360: Connection lost. Either the server is not running or a network problem is preventing access

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Article ID: 112239

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

A new SpectroSERVER was installed in a DSS (Distributed SpectroSERVER) environment, but the OneClick web server cannot access it.



Environment

DX NetOps Spectrum 22.2.x or later

Cause

There could be a few communication issues causing this. 

1. Hostname cannot be resolved and missing hostname in the Host Resource Configuration (.hostrc) File
2. Network/firewall blocks access
3. Tomcat cache needs to be refreshed

Resolution

Test the port connections as follows:

  1. nc or telnet from OneClick server to SpectroSERVER
    [root@OneClick]$ nc -z -v <SpectroSERVER_HOST> 14002
    OR
    [root@OneClick]$ telnet <SpectroSERVER_HOST> 14002

  2. nc or telnet from SpectroSERVER to OneClick
    [root@SpectroSERVER]$ nc -z -v <OneClick_HOST> 14001
    OR
    [root@SpectroSERVER]$ telnet <OneClick_HOST> 14001

Depending on what results are returned, you can do the following:

  • Add the IP/hostname pair in the ~/etc/hosts file. And add the hostname in the .hostrc file via Spectrum Control Panel - Host Security

  • Disable internal firewall on OneClick host

  • Restarted Tomcat service on OneClick host

Additional Information