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Unable to create or rework Knowledge Documents although Knowledge Document functional access is set to an access level of modify.

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Article ID: 112227

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

While signed in with a user with Administrator access type, you may be unable to create or rework a knowledge document although Knowledge Document functional access is set to an access level of modify.

When trying to create a knowledge document the following error is thrown:
"AHD10351:You do not have permissions to modify this document."

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When you go into edit mode on an existing knowledge document, the option to rework the knowledge document is missing and the only option you have is "User View"

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Cause

There is an out of the box "Service Desk Administrator" Pre-Update Data Partition on the SKELETONS table which restricts access to create or modify knowledge documents.

Environment

Service Desk Manager 14.1, 17.x

Resolution

1) Check the contact record of the user to see if they have "Service Desk Administrator" as the set data partition.

2) If so, then navigate to Administration tab -> Security and Role Management -> Data Partitions -> Data Partition List -> Service Desk Administrator

3) The constraint that we need to inactivate is "Pre-Update / Skeleton table / id = 0"

4) After you inactivate this, sign out then sign back in and you should now be able to rework and create knowledge documents. 

Attachments

1558696834174000112227_sktwi1f5rjvs16ioh.png get_app
1558696832005000112227_sktwi1f5rjvs16iog.png get_app