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Add assigned task option missing in New UX Timesheets

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Article ID: 112193

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

The 'Add assigned task' option is missing in the PPM/Clarity New User Experience (UX) for some resources and/or time periods when creating a new timesheet.

Cause

In order for this option to show, the user must have one or more assignments that fall in at least one of the following for the timesheet timeperiod:

  • The assignment start/finish dates fall within the system timesheet population window set in Clarity PPM in Administration->Timesheet Options. (Whether ETC on the task is 0 or not). 
  • One or more tasks assigned with non-zero remaining ETC in time periods that occur after the assignment finish date

Environment

Release: All Supported Releases
Component: Clarity PPM Timesheets

Resolution

  1. Check to make sure the resource has at least one assignment or the timesheet time period that meets one of the below:
    • Assignment start/finish dates fall within the system timesheet population window set in Clarity PPM in Administration->Timesheet Options.  (Whether ETC on the task is 0 or not)
      • Important: The assignment start/finish dates should be checked versus the task start/finish dates, as the system looks at the assignment's start/finish dates in this scenario
      • Check to make sure the pending ETC for the assignment is blank versus 0 (See 117397 for more details on pending ETC behavior)
    • One or more tasks assigned with non-zero remaining ETC in time periods that occur after the assignment finish date
  2. If none are found, the user's assignment(s) would need to be updated for the tasks the user wants to add automatically
    • Update the dates of the assignment for one or more tasks to fall within the criteria mentioned above
    • In the case of assignments with no ETC where the assignment finish date is in the past, adding ETC to the assignment will allow the add assigned tasks option to appear
Note: 
  • The ‘’Add assigned task’’ option cannot be removed by default if any tasks meet the criteria to show up on the timesheet in the New User Interface/Experience. 

Additional Information

See KB: 141061 for tips on how to optimize use of Self Service for Clarity PPM