CA Performance Management Alarms View show no CA Spectrum Alarms
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CA Performance Management Alarms View show no CA Spectrum Alarms

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Article ID: 112112

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

CA Spectrum Alarms do not show in the CA Performance Management Alarm Views.

When select the Alarms Display Dashboard, the Dashboard is displayed but all Views within, such as the Alarms View, the Alarm Details View and others show a spinning progress "Loading..." message.

This continues attempting to load without end until the browser tab is closed, or a new page in the CA Performance Management UI is selected.

Environment

CA Performance Management GA release r3.5 and older releases

Cause

In a Packet Capture between CAPC and Spectrum while reproducing the issue we see: 

Authorization: Basic amdlYWRyaXQ6U3BlY3RydW00MzIxIQ 

The working curl command test shows: 

Authorization: Basic amdlYWRyaXQ6U3BlY3RydW00MzIxIQ== 

When we use "base64 -d" on the commandline, the first Authorization value returns the username:password. At the same time it throws an error about invalid input. 

The Authorization value for the working curl command shows the username:password with no further information. That is expected. 

This proves CAPC is not sending the correct value. 

Further confirmation is the successful wget command run recommended below in the solution details. 

This command was used to validate this: echo -n "authstring" | base64 -d 

Resolution

This is a known defect. It has been resolved in the r3.5 April Monthly Update kit, as well as the GA r3.6 release. 

Symptom: The alarm console shows no data and I see a NullPointerException exception in the PCService.log or an error stating the user name and password are incorrect, even though they are a valid OneCick administrator. 
Resolution: Fixed an issue where the user name and password entered on the Data source screen may not be properly sent to Spectrum. There is a documented issue that the Data source test button does not test the user name and password. The username/password combination should be verified using a utility such as wget. For example: wget --verbose --user=USERNAME --password=PASSWORD http://SPECTRUMHOST:PORT/spectrum/restful/landscapes, where USERNAME is the username and PASSWORD is the password that Spectrum was registered with. This should be a OneClick administrative account password. 
(3.5.0_Apr_Update, DE349641, 00974907,00973448)