Error: 500 on OPTIONS request to a .fcc page in Web Agent
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Error: 500 on OPTIONS request to a .fcc page in Web Agent

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Article ID: 112071

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On SITEMINDER CA Single Sign On Agents (SiteMinder)

Issue/Introduction

 

When running a Web Agent, and when a user tries to reach the page:

 

  https://test.example.com/siteminderagent/forms/login.fcc

  or

  http://myserver2.example2.com:20000/cred/mycustom.fcc?TYPE=[...omitted for brevity...]

 

with OPTIONS as browser action, the browser receives the return HTTP code 500.

 

Environment

 

Web Agent all Versions

 

Cause

 

Web Agent traces show the method OPTIONS isn't supported.

WebAgent.log 

  1. [08/23/2018][16:40:52][2728][2568][CSmHttpPlugin.cpp:698][CSmHttpPlugin::ProcessResource][<Transaction ID>][*10.0.0.1][][Agent][/cred/mycustom.fcc][][Autoauthorizing URL : 'http://myserver2.example2.com:20000/cred/mycustom.fcc?TYPE=[...omitted for brevity...]' , Method: 'OPTIONS' ]
  2. [08/23/2018][16:40:52][2728][2568][CSmHttpPlugin.cpp:8792][CSmHttpPlugin::ProcessAdvancedAuthResource][<Transaction ID>][][][][][][HTTP method options not supported in Advanced Auth]

Web Agent only accepts GET or POST actions on .fcc file.

The Web Agent only receives the request. The method OPTIONS is sent by the browser, and usually, it's the application that instructs the browser to send the request with the OPTIONS method.

 

 

Resolution

 

Ensure the request is sent as a GET or POST to the Web Agent .fcc file to solve this issue.