Agent dies minutes after starting
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Agent dies minutes after starting

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Article ID: 111805

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Updated On:

Products

DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

After installing the agent and starting it up, it dies minutes later. Seems to stay online for about 5 minutes before dying.

Environment

Release:
Component: SYSAGT

Cause

There are many causes for this to occur. 

Resolution

We enabled a higher level of logging to see if we could capture more useful information. As a result, we could see that the connection was timing out and was being reset by the scheduler; eventually the service dies. It is likely that the agent communications port is not correctly defined. Check to make sure that the  communication.inputport setting in agentparm.txt is accurate. It should match what the scheduler knows the port to be. Default port value is 7520, but can be changed at user discretion.