Resolve LDAP Error Code 34 Invalid DN Syntax During Identity Manager and SSO Integration
search cancel

Resolve LDAP Error Code 34 Invalid DN Syntax During Identity Manager and SSO Integration

book

Article ID: 111769

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Suite SITEMINDER

Issue/Introduction

This article explains the resolution for "LDAP error code 34: Invalid DN syntax" occurring during the integration of the Virtual Appliance Identity Manager with Single Sign-On (SSO). This error typically indicates that the LDAP schema required for the SSO Policy Store has not been properly extended.

Environment

Identity Manager 14.5 & 15

Siteminder 12.8

Cause

The error occurs because the LDAP schema for the SSO Policy Store is not extended. This prevents the Identity Manager from successfully creating the necessary directory objects.

Resolution

  1. Verify the type of LDAP being used as the Policy Store.
  2. Extend the LDAP schema according to the official CA Single Sign-On documentation.
  3. For CA Directory specifically, ensure the schema extension is applied successfully.
  4. Once the schema is extended, attempt to create the directories and environment again.

Additional Information

Refer to the official documentation for detailed instructions: Configure the CA SSO Policy Store - 14.5 or Configure the SiteMinder Policy Store - v15

To speak with a customer representative or a Support Engineer see Contact Support. Scroll to the bottom of the page and click on your respective region.