Clarity: SaaS Environment - Logs show error No space left on device

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Article ID: 111610

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

One or more of the following symptoms occur:
-Clarity displays error:“System error. Contact system administrator.” when navigating to the Resource List View
-Jobs fail with error 

java.io.IOException: No space left on device at java.base/java.io.UnixFileSystem.createFileExclusively(Native Method) at java.base/java.io.File.createNewFile(File.java:1024) at org.apache.lucene.store.SimpleFSLock.obtain(SimpleFSLockFactory.java:144) at org.apache.lucene.store.Lock.obtain(Lock.java:73) at org.apache.lucene.index.IndexWriter.init(IndexWriter.java:691) at org.apache.lucene.index.IndexWriter.<init>(IndexWriter.java:452) at com.niku.search.engine.lucene.LuceneIndexEngine.optimizeIndex(LuceneIndexEngine.java:694) at com.niku.search.engine.lucene.LuceneIndexEngine.optimizeSearchContentIndex(LuceneIndexEngine.java:678) at com.niku.search.engine.lucene.LuceneIndexEngine.index(LuceneIndexEngine.java:766) at com.niku.search.nspider.Nspider.scheduledEventFired(Nspider.java:187) at com.niku.njs.Dispatcher$BGTask.run(Dispatcher.java:657) at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)

Cause

We found these error messages in the app-ca.log file:

Error message: [CA Clarity][Oracle JDBC Driver]Error writing data to client-side row cache. Verify that the directory specified by the java.io.tmpdir property exists and the current user has permission to read from and write to that directory. 
SQL error code: 0 

Error message: [CA Clarity][Oracle JDBC Driver]IO Error writing temp file: No space left on device

Environment

All Clarity versions

Resolution

The SaaS team will need to clear out log files from the NAS drive supporting the APP server because it is full.