Unable to open DSM Explorer, progress bar stuck at retrieving portal data
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Unable to open DSM Explorer, progress bar stuck at retrieving portal data

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Article ID: 111554

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Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

After changing the "certificate preference" to support "SHA256_2048" only, and with patch T533300 (DSM EXPLORER HUNG) applied, replacing cfcertidentity.dll, DSM Explorer no longer opens, and the progress bar is stuck at one of the following areas:

Retrieving SD portal data
Retrieving RC portal data


Example:

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Reference certificate preference policy:

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Default Computer Policy --> DSM --> Common Components --> Security --> Certificates Options --> Certificate Preference:

Default value is: "SHA256_2048,SHA1_1024"
SHA256 only is: "SHA256_2048"

The problem occurs when the preference policy is set to "SHA256_2048", and T533300 is applied to the Domain Manager.

Environment

Client Automation -- r14 SP1 only

Cause

Patch T533300 addresses a scenario where r14 GA or earlier DSM Explorer is unable to communicate with an r14 SP1 Domain Manager, due to the introduction of the dual certificate store feature, where ITCM now utilizes SHA256 certificates.  Unfortunately there is an unforeseen issue with this patch, when the certificate preference is changed to use SHA256 certificates, only.

Resolution

Remove patch T533300 from the ITCM Domain Manager, and restore the previous or original cfcertidentity.dll file.

It is highly recommended to use the cfcertidentity.dll patch from T437262, a patch written to address several memory leaks in the r14 SP1 release of the product.  Open a case with Support in order to receive the latest WinOffline rollup for r14 SP1.

Refer to the recommended patch KB article:
https://comm.support.ca.com/kb/what-are-the-client-automation-itcm-recommended-fixes/kb000013928

Attachments

1558697321998000111554_sktwi1f5rjvs16iwm.jpeg get_app
1558697320194000111554_sktwi1f5rjvs16iwl.jpeg get_app