vmware probe reporting negative values for performance counters
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vmware probe reporting negative values for performance counters

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Article ID: 111550

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The vmware probe might report negative values for certain QOS metrics, for example QOS_VMWARE_VM_DISK_AGGREGATE_MAX_TOTAL_LATENCY, QOS_DISK_COMMANDS_ISSUED QOS_CPU_USAGE, etc.

This behavior is not limited to the QOS metrics above but to any performance metrics collected from VMWare.

When viewing these metrics through the VMware vSphere Client these incorrect numbers are not displayed. They are shown as 0 at that same point in time.

Environment

Any supported UIM version
vmware 6.87
VMWare vCenter version 6.0.0 
ESXi version 6.0.0

Cause

When performance counters are unavailable in the VMWare system (vCenter or ESX host) it will be reported as -1.

With the design of the vmware 6.87 probe it publishes the value reported by the monitored system regardless of it being negative.

Resolution

The following key needs to be added to the setup section of the probe config to enable the new feature:( applicable to vmware probe 6.87 HF9 and higher) 

enable_null_for_data_not_available = true 

With the above key in place the probe will update the metric with null value for that polling cycle instead of -1.