Clicking on Search replicates HTTP 400 errors within Catalog
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Article ID: 111492
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Updated On:
Products
CA Service CatalogCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
Actual, they are three places where the problem had occurred cq the HTTP400 appeared. In 'Search page', in 'Cancel the Request' and in 'ERA edit'.
One scenario to reproduce is: 1. Login to Service Catalog 2. Select My Requests 3. Select Find Requests 4. Enter request number you want to search for and hit search 5. Click on the request name to load up the detail as usual
Once you are in the request itself, if you then try to click on search, its giving the error HTTP 400 Error Home>Requests>Search>Request Details
Environment
Windows running CA Service Catalog.
Cause
The cause got identified in that they are using 7.0.82 tomcat version. And it has some issues in allowing special characters in the URL.
Resolution
In order to get this working, we need to add the below line in the configuration file: viewservice.conf file. As to be found in folder C:\Program Files\CA\Service Catalog\view\conf of the CA Service Catalog folder-tree. wrapper.java.additional.23=-Dtomcat.util.http.parser.HttpParser.requestTargetAllow=|
Note1. The value of 23 depends on the lines already in there. Note2. Another character to 'allow' is '^'.
Additional Information
Note. The value of 23 depends on the lines already in there. So this value may need to be set different than in this example.