Error "Security violation in CloseTicket. AHD03300" When trying to close ticket in Service Desk Manager from Spectrum integration

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Article ID: 111412

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

The following error appears in stdlogs from Service Desk Manger when trying to close a ticket through the integration with Spectrum:

4880 ERROR sda.cpp 2482 Security violation in CloseTicket. AHD03300: This operation requires Function Access for call_mgr equal to View or Modify

Cause

The spectrum contact created for the integration (see link in the Additional Information section) does not belong to the tenant where the tickets from Spectrum are being created and cannot be closed.

Environment

Service Desk Manager 14.1
Spectrum 10.2

Resolution

1. Log into Service Desk Manager as an administrator (ex: ServiceDesk)
2. Administration > Security and Role Management > Contacts > Search for the user set for the integration (ex: spectrum) > Open contact
3. Edit the tenant and set the tenant where the tickets are being created.

Additionally, confirm the role assigned to the contact (through Access type or directly) has the call_mgr function access set to Modify.
 

Additional Information

Create a Contact, Service Desk Ticket Template, Service Desk Web Services Policy, and Service Desk Notification Method

https://docops.ca.com/ca-spectrum/10-2-3/en/integrating/ca-service-desk-and-ca-spectrum/how-to-install-and-configure-the-integration/configure-the-ca-service-desk-manager-server